首页 新闻动态 资料下载 尊享服务 管道配件

资料下载

你的位置:【开元ky888棋牌免费下载官网娱乐】 > 资料下载 > 抄底范例选股公式及告成率回测数据(匀称收益率20日3.37%)

抄底范例选股公式及告成率回测数据(匀称收益率20日3.37%)

发布日期:2022-09-07 02:35    点击次数:118

危险提示:好的公式名称不必定担保投资的告成率和收益率,高收益率公式假定出现旗子灯号太多也无操作价钱,短时辰收益率低不必定长岁月收益率也低,因而需求亲身去测试,材干防止投资盈余。

选股公式源码

X_1:=REF(CLOSE,1);

X_2:=SMA(MAX(CLOSE-X_1,0),2,1)/SMA(ABS(CLOSE-X_1),2,1)*100-50;

X_3:=X_2<(-45);

X_4:=CROSS((-40),X_2);

X_5:=X_3 OR X_4;

X_6:=X_5 AND CLOSE>OPEN;

X_7:=10;

X_9:=100*(HHV(HIGH,X_7)-CLOSE)/(HHV(HIGH,X_7)-LLV(LOW,X_7));

X_10:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));

X_11:=X_9>90 OR X_10>90;

X_12:=5;

X_16:=IF(DATE<1900612,1,1);

X_17:=(HIGH+MAX(CLOSE,OPEN))/2;

X_18:=MA(X_17,3);

X_22:=(HIGH+LOW+CLOSE+OPEN)/4;

X_23:=MA(X_22,3);

X_24:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2) AND REF(MIN(CLOSE,OPEN),1)>REF(MAX(CLOSE,OPEN),2);

X_26:=(X_23-(REF(X_23,1)-X_23)-LOW)/LOW*100;

X_27:=(X_18+(X_18-REF(X_18,1))-LOW)/LOW*100;

X_30:=IF(X_24,X_27,X_26);

X_33:=SMA(LOW,4,3);

X_36:=REF(LOW,1)-HHV(MAX(REF(LOW,2),资料下载REF(LOW,1))-MIN(REF(LOW,2),REF(LOW,1)),2);

X_37:=REF((CLOSE+OPEN)/2,1)>REF((CLOSE+OPEN)/2,2);

X_38:=LOW<=X_36+X_36*0.01 AND OPEN>REF(OPEN,2) AND OPEN>=REF(LOW,3) AND COUNT(CLOSE>OPEN,7)>3;

X_39:=(X_36-LOW)/LOW*100;

X_41:=(X_33-LOW)/LOW>X_12/1000;

X_42:=X_41;

X_43:=(REF(HIGH,1)-OPEN)/OPEN*100-(REF(MAX(CLOSE,OPEN),2)-REF(MAX(CLOSE,OPEN),1))/REF(MAX(CLOSE,OPEN),1)*100;

X_44:=IF(X_37,X_39,X_43);

X_45:=X_39+X_44>2;

X_46:=IF(X_37,X_38,X_45) AND X_30>2;

X_47:=X_16 AND X_42 AND X_46;

旗子灯号:REF(X_47,1) AND LOW<REF(LOW/0.995,1) AND X_6 AND X_11;

选股公式翻译

X_1赋值:1日前的收盘价

X_2赋值:收盘价-X_1和0的较大值的2日[1日权重]移动匀称/收盘价-X_1的绝对于值的2日[1日权重]移动匀称*100-50

X_3赋值:X_2<(-45)

X_4赋值:(-40)上穿X_2

X_5赋值:X_3 OR X_4

X_6赋值:X_5 AND 收阳线

X_7赋值:10

X_9赋值:100*(X_7日内最低价的最高值-收盘价)/(X_7日内最低价的最高值-X_7日内最自制的最低值)

X_10赋值:100*(6日内最低价的最高值-收盘价)/(6日内最低价的最高值-6日内最自制的最低值)

X_11赋值:X_9>90 OR X_10>90

X_12赋值:5

X_16赋值:假定日期<1900612,前去1,否则前去1

X_17赋值:(最低价+收盘价和收盘价的较大值)/2

X_18赋值:X_17的3日俭朴移动匀称

X_22赋值:(最低价+最自制+收盘价+收盘价)/4

X_23赋值:X_22的3日俭朴移动匀称

X_24赋值:1日前的(收盘价+收盘价)/2>2日前的(收盘价+收盘价)/2 AND 1日前的收盘价和收盘价的较小值>2日前的收盘价和收盘价的较大值

X_26赋值:(X_23-(1日前的X_23-X_23)-最自制)/最自制*100

X_27赋值:(X_18+(X_18-1日前的X_18)-最自制)/最自制*100

X_30赋值:假定X_24,前去X_27,否则前去X_26

X_33赋值:最自制的4日[3日权重]移动匀称

X_36赋值:1日前的最自制-2日内2日前的最自制和1日前的最自制的较大值-2日前的最自制和1日前的最自制的较小值的最高值

X_37赋值:1日前的(收盘价+收盘价)/2>2日前的(收盘价+收盘价)/2

X_38赋值:最自制<=X_36+X_36*0.01 AND 收盘价>2日前的收盘价 AND 收盘价>=3日前的最自制 AND 统计7日中餍足收阳线的天数>3

X_39赋值:(X_36-最自制)/最自制*100

X_41赋值:(X_33-最自制)/最自制>X_12/1000

X_42赋值:X_41

X_43赋值:(1日前的最低价-收盘价)/收盘价*100-(2日前的收盘价和收盘价的较大值-1日前的收盘价和收盘价的较大值)/1日前的收盘价和收盘价的较大值*100

X_44赋值:假定X_37,前去X_39,否则前去X_43

X_45赋值:X_39+X_44>2

X_46赋值:假定X_37,前去X_38,否则前去X_45 AND X_30>2

X_47赋值:X_16 AND X_42 AND X_46

输出旗子灯号:1日前的X_47 AND 最自制<1日前的最自制/0.995 AND X_6 AND X_11

条件选股:抄底范例[日线]告成率测试

测试股票数:4926

共收回旗子灯号:9699 告成旗子灯号:4847 失利旗子灯号:4821 未实现旗子灯号:31

旗子灯号收回率:66.20% 匀称告成率:50.13% 告成率达到50%的股票数有:58.11%

利润1总匀称:15.33% 最大匀称利润1:  430.47%  最小匀称利润1:  0.00%

利润2总匀称:3.37% 最大匀称利润2:  402.16%  最小匀称利润2:  -42.15%

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。

上一篇:起床三慢,吃饭三少,入睡三宜

下一篇:没有了